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Copyright, Registration, Technical Support

This system was developed by Informatik Inc, P.O. Box 868, Devon, Pennsylvania 19333.    For 
information on program modifications, systems integrations and custom applications, please contact 
Informatik Inc.

This is a copyright-protected shareware product.    If, after review and evaluation, you like the 
software, please register and pay the registration fee.    Upon registration and payment of the 
registration fee, Informatik Inc will send you the latest master diskette, a printed User Guide and a 
registration certificate.    Registered users will receive lifetime technical support and are entitled to 
free software upgrades during first year.    Shareware is based on trust, and we hope that all users 
will register. 

To register

From the About menu, choose Registration, Copyright and follow the instructions.

To obtain technical support

From the Help menu, choose Technical Support and follow the instructions.

© 1995 Informatik Inc
All rights reserved



Introduction to HTML

Web browsers and navigators read HTML files and translate the text, tags, codes and references 
contained in the HTML files to multi-media displays.    HTML files are plain ASCII text files made up 
of a collection of some simple and some complex codes and tags. 

WebPen helps you create the correct syntax and structure of the HTML document.    It is important, 
however,    that you are somewhat familiar with the HTML concept before you attempt to build the 
first HTML file.    You are familiar with HTML if you can understand the general meaning of an HTML 
script.    Reading a HTML script is similar to reading the 'reveal code ' of a word processing 
document.      It is suggested that you read a book about HTML, or at least read the document 'A 
Beginner's Guide to HTML'    published by the National Center for Supercomputing Applications, 
available via the Internet (http://www.ncsa.uiuc.edu/General/Internet/www/HTMLPrimer.html).

Not all features included in the WebPen are supported by all web browsers and navigators.    
If a function does not work, it probably means that your browser does not support the 
feature.

Structure of the HTML document

The HTML document uses paired ON and OFF tags to specify attributes and conditions.    For 
example, to specify a certain    text to be displayed bold, a ON tag (<B> is placed in front of the 
bolded text and a OFF tag (</B> is placed at the end of the bolded text.    OFF tags are identified by 
the 'slash' sign (/).

All HTML document must start with a <HTML> tag and end with a </HTML> tag.    The document is 
sub-divided into two sections: the Heading Section (<HEAD> .....</HEAD>) and the Body Section 
(<BODY> .......</BODY>).

The Heading Sections contains the Title (>TITLE> ......</TITLE>). The Body Section contains the 
substance of the document.

The structure thus looks like this:

<HTML>
                <HEAD>
                                <TITLE> 
                                                The title .....
                                </TITLE>
                </HEAD>
                <BODY>
                                Text......
                                Text .....
                                Text .....
                </BODY>
</HTML>

Spaces, tabs, carriage returns are ignored by the browser software (except for preformatted text).      
All line breaks, paragraph breaks, indentations, etc. must be specified by tags.    To insert a line 
break (CR), press Function Key 9 or choose Line Break from the Insert menu.





Open New, Open File

To start a new HTML file, choose New from the File menu.    The system creates the basic structural 
tags for the HTML document.

To open an existing HTML file, choose Open from the File menu.    In the dialog box, select the drive,
directory and file and press OK.    



Create and Modify HTML Files

There are two methods of entering HTML text and elements: 
a) type in the editor window, b) inserting and c) formatting.    

The following elements are inserted:

Line breaks 
Headings
Double line breaks (equivalent to a new paragraph)
Horizontal rules

    Hypertext references and anchors
Graphics
Colored bullets
Copyright, notice, e-mail prompt and signature section, 'Return to Top'
Current date
Special characters

The following elements are typed in the edit window, highlighted with the cursor and then formatted:

Bold, underline, italic, superscript, subscript
Emphasis
Paragraphs
Blink
Preformatted text
Lists (numbered and un-numbered)
Address block
Extended Blockquote (indents)
Centered
Current date

Insert HTML Elements

The basic structural <HTML>, <HEAD>, <TITLE> and <BODY> tags are automatically inserted by 
the system when a new document is created.    You may of course edit these tags.

To insert other elements, such as horizontal rules, graphics, etc.:

1. Place the insertion point at the exact spot where you want to insert the element.    

2. From the Insert menu, select the item.

3. In the prompts, select the options and enter the text values as appropriate.    If you have 
highlighted some text before choosing Insert, the highlighted text will be shown as a default 
entry.

4. Choose OK.



Format HTML elements and text

To create lists, indentations (extended quote blocks), address blocks, paragraphs, pre-formatted 
text, text attributes, etc.:

1. Type the text in the editor window.

2. Highlight the text with the mouse.

3. From the Format menu, select the formatting action.

4. If required, specify the options and press OK.

To insert a line break (CR), press Function Key 9 or choose Line Break from the Insert menu.   
HTML ignores keyboard carriage returns and tabs. 

Search

WebPen includes a simple word search function.    To search for a text string in the current 
document, choose Search Forward from the Edit menu, type the word you are searching and press 
OK.    To search for the next hit, repeat the process.    The system searches for the word from the 
point of the cursor forward.

Graphic Images

It is important that the image files used in the web page be in the directory of the application.    From 
the Insert menu, choose Graphic Image.    The Graphics window is displayed.    Press on Browse and
select the picture (click it).    Optionally, change the position, size and attributes of the picture and the
location of the accompanying text, or keep the defaults.    There are many options, and you will need 
to experiment with them.    In the Alternate box, type the description that you want to show in lieu of 
the picture in cases where the web browser does not support pictures.    In the Text box, type the text
that accompanies the picture.    Press OK.

The specifications for the position and size of graphics and the alignment of the accompanying text 
is as follows:

To print a single line of text at the bottom right-side of the image, make no alignment selection.    This
is the default setting.

To print a single line of text at the top right-side or middle right-side of the image, select Right or 
Middle from the Text Alignment list.

To place the image at the left side of the page and wrap (several lines of) text to the right of the 
image, select Left from the Text Alignment list.

To place the image at the right side of the page and wrap (several lines of) text to the left of the 
image, select Right from the Text Alignment list.



Lists

There are several formats of lists.    To create a list, type the text in the editor window.    Then, 
highlight the text of the list and    choose List from the Format menu.    

You can also create nested lists.    To create a nested list, first create the first level of list items, as 
indicated above.    Then, place the cursor at the location where you want to insert the nested list and 
create another list as indicated above.

The colored bullet lists are created one line at the time.    To create a colored bullet, choose Colored 
Bullet from the Insert menu.    In the Colored Bullet window, type the text, select a color and press 
OK.    You may also type the text in the edit window.    

Preformatted Text

Sometimes you may wish to insert preformatted text.    Preformatted text will be displayed by the web
browser 'as is' with tabs, carriage returns, etc. honored.    To create Preformatted Text, type the text 
in the editor window (or paste it in).    Highlight the text and choose Preformatted Text from the 
Format menu.

Paragraphs

Web browsers ignore carriage returns.    To create a paragraph, type the text, highlight it and choose 
Paragraph from the Format menu.    The same effect can also be accomplished with a double line 
break (<br> <br>).

Blockquotes, Indentations

Web browser do not honor tab or indents.    To create an indented text, you must create Blockquotes.
Type the text in the editor window, highlight it and select Blockquote from the Format menu.

Horizontal Rules, Lines

Most web pages make (too) extensive use of horizontal rules.    To create a horizontal rule, place the 
insertion point at the position where you want to create the rule and choose Horizontal Rule from the
Insert menu.    In the Horizontal Rule window, select the size (thickness) and the width of the rule.    
All measurements are in pixels or percent.    The window indicates the conversion factors for your 
screen.    Press OK.

There are other options for advanced applications, and these are outside the scope of this user 
guide.    Some functions may not work on all web browsers.

Forms



For more advanced applications, you may want to add a fill-out form on a web page.    The form can 
include text boxes, radio buttons, pull-down lists.    The web audience fills out the form and the web 
browser automatically transmits the data back to the web owner via the built-in e-mail system.    
WebPen does not have a direct function to create such a form, because there are so many ways to 
structure the form.    However, in the application's directory you will find a file named FORM.HTM 
with a sample of such a form.    Simply copy and paste the relevant sections of the sample into your 
web document.



Edit Files

The primary purpose of the system is to create HTML elements with the correct syntax.    If you need 
to change an existing element, you should edit simple changes directly in the edit window by 
overwriting the original text.    Be careful not to damage the syntax.    Major modifications are best 
made by deleting the old text and recreating the element.



View the Web Page

When you have completed the HTML document, you will be eager to view the result of your creation.
The HTML document can be viewed with any web browser, such as the Netscape Navigator. 

1. Save the document.    From the File menu, choose Save As (or Save).

2. Start the Web Navigator.
 
3. From the browser's File menu, choose Open File (or Open Local) and select the HTML file.    

Press OK.

4. If you have viewed the file earlier and the browser is still running, simply activate the browser
and choose Reload from the View menu.



Save the File, Print

When you have completed the editing, you should save the file.    

From the File menu, choose Save As for a new file and specify the file number with a .HTM 
extension.    If you have previously saved the file, choose Save from the File menu.

To print the file, choose Print from the File menu.    Optionally, select the printer from the Setup 
Option. Press OK.



Upload the HTML File to the Server

Once you are happy with the HTML document, you must upload the file to your web server.    You will
normally use the FTP function to transfer the file.    Please ensure that all relating files, especially the 
graphic files are also transferred to the correct directory on your web server.    If the document uses 
colored bullets, these graphic files must also be uploaded.    The names of the graphics files can be 
found in the raw HTML text (The bullet graphic files are named blue.gif, red.gif, etc).

It is important that the name of the main home page be INDEX.HTML.    If you have used another 
name for the main page, you can change the name directly on the web server.    Also, some web 
servers require the extension names of the HTML files to be HTML (not HTM, the extension used on 
your Windows system).    If so, you can rename the files directly on the web server.

You should now try to access the remote web server.    If some of the linked items or graphics do not 
appear, verify the pathname of the links.

 



Tutorial 

1. From the File menu, choose New.    The Title window appears.

2. In the Title window, enter a meaningful title.    The words in the title text will be used by many 
search engines for their index.    Press OK.    The edit window displays the basic HTML structure
and the text of the title.

3. Ensure that the insertion point is placed just below the <BODY> tag.

4. From the Insert menu, choose Heading (the first item in the menu.    The Heading window is 
displayed.    Type a heading.    You may specify a size and an alignment or keep the defaults.    
Press OK.

5. From the Insert menu, select Horizontal Rule.    The Horizontal Rule window is displayed.    You 
may change the thickness of the line, the length and the alignment.    Generally, you will keep 
the default.    Press OK.

6. Now we want to create a list.    In the edit window, type a list of items, let's say four lines.    
Highlight the listed items and choose List from the Format menu (not Insert menu).

7. Now we will insert a picture.    First, you must transfer the picture to the WebPen's directory (the 
directory that holds the WEBPEN.EXE file, not necessarily the directory of the HTML file)..    
There are already some pictures in the directory, so we can proceed.    From the Insert menu, 
choose Graphic Image.    The Graphics window is displayed.    Press on Browse and select the 
picture (click it).    Optionally, change the position, size and attributes of the picture and the 
location of the accompanying text, or keep the defaults.    There are many options, and you will 
need to experiment with them.    In the Alternate box, type the description that you want to show 
in lieu of the picture in cases where the web browser does not support pictures.    In the Text 
box, type the text that accompanies the picture.    Press OK.

8. To insert a line break (CR), press Function Key 9 or choose Line Break from the Insert menu.    
HTML ignores the regular keyboard carriage returns.    

9. Now we will sign off.    From the Insert menu, choose Author Signature.    The Author Signature 
window appears.    Enter your e-mail address and press OK.    

The Insert menu also has functions for the copyright notice and the 'Return to Top'.    Try them 
out.

10. Now we must save the document.    From the File menu,    choose Save As.    Specify the file 
name (the extension name must be htm).    Press OK.

11. Start up your Web    Browser Navigator.    From the File menu of the browser, choose Open File 
(or Open Local, or equivalent).    Your masterwork is displayed.



Hypertext Links 

Web pages can be linked to other web pages, internal or external.    You create a link to another 
page, a location on the current web document or another Internet service by marking the object as 
'hypertext'.    Both text and pictures can be hypertext objects.

To link to another web page:

1. In the editor window, place the insertion point where you want to insert the hypertext.

2. From the Insert menu, choose Hypertext Link.    The Hypertext Link window is displayed.

3. In the first box, specify the path of the linked page, normally the URL.    The full path must be 
entered if the linked page is not in the same directory as the linking page.    If the linked page is 
in the same directory, you need only enter the file name.

4. Optionally, in the second field, specify the reference name of the linked location on the page.    
The reference name must exist in the linked document.    

To create a reference name, place the cursor at the exact spot where you want to insert the 
reference, then choose Location Name from the Insert menu.    In the Location Name window, 
enter the reference name and press OK.

5. In the third field, enter the visible text that will become the hypertext. 

6. Press OK.

To link to a spot on the same web page

Proceed as above, but leave the first field blank.

To make a hypertext picture
 

1. Create a picture (From the Insert menu, choose Graphic)

2. In the edit window, with the cursor, highlight the entire specification relating to the picture.    
Make sure that you exclude any <br> tags.

3. Proceed as above, but do not change the Picture specifications in the third field.




